Task processor down

Incident Report for Flagsmith

Resolved

All issues with the asynchronous task processor have been resolved and all operations in the Flagsmith UI are working as expected.
Posted Oct 23, 2025 - 14:49 UTC

Monitoring

We have resolved the issue with the task processor and are no longer seeing issues with the Flagsmith UI. We are continuing to monitor performance of the task processor.
Posted Oct 23, 2025 - 10:26 UTC

Investigating

We are currently investigating an issue with the Flagsmith asynchronous task processor, impacting flag change events, webhooks and audit logs in the Flagsmith UI.
Posted Oct 23, 2025 - 10:08 UTC
This incident affected: Admin Dashboard.